Barracuda Backup (BBS) – Slow Offsite Replication Performance - U.S. Region
Incident Report for Sunshine 811
Resolved
This incident has been resolved.
Posted Mar 26, 2021 - 09:37 EDT
Investigating
We are investigating an issue impacting some U.S. Barracuda Backup customers replicating data offsite. Customers replicating data offsite to the Barracuda Cloud may experience slow transfer speeds. Additional details will be provided once they become available.
Posted Mar 26, 2021 - 08:27 EDT